This project is read-only.
2

Closed

.NET Framework 4.0 and VB 2010 support

description

Since Framework 4.0 and VB 2010 are out I was thinking about adding a better support for them, because the current one is terrible. You have to re-target your project for .NET 3.5 or earlier to get rid of errors, and some instructions in the documentation area are outdated, since VB 2010 is (a bit) different than 2005. Doing so would make my work much easier, because I'm still strugling with Task dialogs (just can't get them to work).
 
So what do you think?
Closed Aug 14, 2011 at 3:54 PM by Lck
.NET 4.0 framework support has been added in trunk.There are now two solutions available: the 2.0 one (which is compatible with .NET up to version 3.5) and the 4.0 one.

comments

Lck wrote Oct 6, 2010 at 10:19 AM

Will look into it in the next weeks.

TaskDialog documentation should be pretty complete at http://windowsformsaero.codeplex.com/wikipage?title=Task%20Dialogs&referringTitle=Documentation. Will check and try to improve it however. :)

xiaoyang wrote Jan 1, 2011 at 12:37 PM

You can try re-biuld the libraries in C# 2010, and change the .net version. I make it to .net framework 3.5.

Marcos2015 wrote Jun 4, 2011 at 7:51 PM

Actually, you must target the FULL FRAMEWORK, not CLIENT PROFILE in order to get the app to start.

wrote Aug 14, 2011 at 3:54 PM

wrote Feb 14, 2013 at 8:09 PM

wrote May 16, 2013 at 9:45 AM